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Other symbols

These symbols are used within this document 
as follows: 

Note, e.g. specific instructions regarding 
efficient and cost-effective use of the unit. 

Refer to Operating Instructions.

Action instructions are identified specifically in 
this document:
	i Perform this action.

1.2	 Copyright information
All circuits, processes, names, software pro-
grams and units mentioned in this document are 
protected by copyright. 
The Installation and Operating Instructions must 
not be copied or reprinted, neither in full nor in 
part, without written authorisation from 
Dürr NDT. 

Important information

1	 About this document
This manual forms part of the software. It cor-
responds to the version of the software and the 
technical standards valid at the time of installa-
tion.

Dürr NDT accepts no liability or responsi-
bility for safe operation of this unit and 
the software if the notes and instructions 
contained in this manual are not ob-
served.

1.1	 Warnings and symbols

Warnings

The warnings in this document are intended to 
draw your attention to possible injury to persons 
or damage to machinery. 
The following warning symbols are used:

General warning symbol

The warnings are structured as follows:

SIGNAL WORD

Description of the type and source of 
danger

Here you will find the possible conse-
quences of ignoring the warning
	i Follow these measures to avoid the 
danger.

The signal word differentiates between four 
levels of danger: 
	– DANGER

Immediate danger of severe injury or death
	– WARNING

Possible danger of severe injury or death
	– CAUTION

Risk of minor injuries
	– NOTICE

Risk of extensive material/property damage
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2.3	 Protection from threats from 
the Internet

The software runs on a computer that can be 
connected to the Internet.
Therefore, the system needs to be protected 
from threats from the Internet.
	i Use, properly configure and regularly update 
your firewall.

	i Update the computers operating system regu-
larly.

	i Perform regular data backups.
	i Provide access to computers to authorised 
users only, e.g. by means of user name and 
password.

	i Make sure that only trustworthy content is 
downloaded. Only install software and firm-
ware updates that have been authenticated 
by the manufacturer.

2	 Safety
This section contains important safety 
information.
This section is divided into the following 
sub-sections:
	– „2.1 Functions“
	– „2.2 Specialist personnel“
	– „2.3 Protection from threats from the Internet“ 

2.1	 Functions
D-Tect X is intended for examination and evalu-
ation of image data with nondestructive material 
inspection.
D-Tect X is used for the following tasks:
	– Acquisition, storage, management, display, 
analysis, evaluation, and editing of digital/dig-
itised X-ray images

	– Filter optimisation of the display of X-ray imag-
es for improved evaluation

	– Forwarding of images and additional data to 
external software (third-party software)

The image data for the selected task is saved 
and can be displayed optimised for evaluation 
support. Image data can be imported and 
exported in various graphics formats together 
with the metadata.

2.2	 Specialist personnel
Persons using the software must be able to 
guarantee safe and correct operation based on 
their training and experience.
	i Make sure every operator is trained in the use 
of the software.

	i Installation, configuration, alteration, extension 
and repair work must be carried out either by 
DÜRR NDT personnel or by a suitably quali-
fied person approved by DÜRR NDT.
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Installation

This section covers the installation and configu-
ration of the software ready for use in the default 
configuration.
In addition, uninstallation and data backup are 
described.

Installation and configuration must only 
be performed by DÜRR NDT or by a 
person or company authorised to do so 
by DÜRR NDT.

This section is divided into the following 
sub-sections:
	– „3 Software“
	– „4 Data backup“

Installation is started via the Start menu of the 
D-Tect X Download installation package 
("https://dtectx.com").

3	 Software

The Microsoft® Windows® 10 opera
ting system is required for installation 
and operation of the software.

This section is divided into the following 
sub-sections:
	– „3.1 Installing the software“
	– „3.2 Launching the software for the first time“
	– „3.3 Uninstalling the software“
	– „3.4 Repairing the software“

Before installing the software, we recommend 
you perform a complete data backup for the 
software already installed on the computer.
We also recommend that you uninstall any anti-
virus software while you are performing the in-
stallation.
To prevent accidental triggering of antivirus 
alarms and in order to increase speed, we re
commend excluding the following directory from 
the antivirus scan after installation:
	– C:\ProgramData\Duerr NDT\D-Tect X

The directory mentioned refers to the standard 
installation. This directory may differ, depending 
on the information entered during installation.
Confirm all Windows security queries, e.g. UAC, 
firewall, so that the software works properly.

3.1	 Installing the software
	i Save the installation file locally.
	i  D-Tect X 1.0.0.1749.exe.

	i Read the licensing agreement.
	i Confirm agreement with the licensing condi-
tions with þ. The installation cannot proceed 
without a declaration of consent.

	i To improve D-Tect X, confirm the option 
"Send anonymised usage data" with þ.

	i Confirm the option "Add an exception for 
D-Tect X in the Windows firewall" with þ.

	i Click Install.

	i After successful installation, start the software 
for the first time.
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3.2	 Launching the software for the 
first time

After the software is started for the first time, 
a valid licence key must be entered and activa
ted.

3.2.1. Online activation

An active internet connection is required 
to activate the licence.

	i Enter a valid licence key.
	i Click Activate.
	i After the valid software licence has been con-
firmed, close the dock.

3.2.2. Offline activation

For PCs that are not connected to the Internet, 
there is a special offline activation procedure.
You can find more information at: 
https://dtectx.com/activation

For further information on licensing, see 
„23 Licensing“.

3.3	 Uninstalling the software
The D-Tect X software package essentially con-
sists of two components:
	– The D-Tect X program software

The directories that need to be backed up may 
vary depending on your specific installation. You 
can contact our hotline to make sure that all 
task data and the databases are backed up.
Proceed as follows to uninstall the software:
	i Start the uninstall process via Start > 
Settings >  Apps > D-Tect X > Uninstall.

3.4	 Repairing the software
If the software malfunctions, instead of reinstall-
ing it, you can try to repair any damaged com-
ponents of the software by using the Repair op-
tion.
	i Start the process via Start > Settings > 
Apps > D-Tect X > Change > Repair.

4	 Data backup
Regular data backup of the D-Tect X image di-
rectories is strongly recommended, especially if 
there is a retention period for X-ray images.
For a complete data backup, the following di-
rectory must be backed up:
The directory mentioned refers to the standard 
installation.
We recommend backing up the above directory 
via the backup routines in your company. You 
can request instructions on how to proceed 
from your system administrator.
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First steps

This section describes the initial steps that need 
to be taken in order to use the software.
This section is divided into the following 
sub-sections:
	– „5 Notes on use“
	– „6 Starting the software“
	– „7 Configuration settings“
	– „13 Arrange docs“

The following configurations are required in or-
der to work with the software:
	– „15.1 Create task“
	– „14 Devices“

 

Notice

Risk of data loss due to incorrect 
configuration

	i Have configuration be carried out by 
DÜRR NDT or a company authorised 
to do so by DÜRR NDT.

5	 Notes on use
Please refer to the following sections on use of 
the software:
	– „5.1 Software interface“
	– „5.2 Saving concept“
	– „5.3 User support“

Open the software help on the start page:
	i Click "Menu > Help".
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5.1	 Software interface

„A1	 Menu bar (left area)“
„A2	 Menu bar (right area)“
„A3	 Working area“
„A4	 Working Area menu“
„A5	 Image menu“
„A6	 Image footer“
„A7	 Tasks“
„A8	 Tools“
„A9	 History“
„A10	 Devices“
„A11	 Status bar“

The software interface is described in the default configuration. Its appearance may differ 
depending on how it is configured.
The software interface can be reset via the menu View -> Profile -> Standard.
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Images and functions are grouped in the Tasks 
and Tools area. The groups can be opened or 
closed by clicking the group title.

B.1	 Function group Filter (closed)
B.2	 Function group Zoom (opened)

The following buttons can be used to open or 
close all groups simultaneously:

Expand all

Close all

Quick information with a brief explanation is 
saved for the buttons on the software interface.

If you briefly hover with the mouse cursor over a 
button the quick information will be displayed.

A1	 Menu bar (left area)

	– File menu
	– View menu
	– Layout menu
	– Help menu
	– Create New Task icon
	– Import Images icon
	– Export Images icon

A2	 Menu bar (right area)

	– Configuration
	– Errors, warnings, messages

A3	 Working area

The images selected in the image list can be ed-
ited in the working area.

A4	 Working Area menu

The Working Area menu contains various com-
mands for the images displayed:

0/2 Select all frames 
(no frame selected)

1/2 Select all frames 
(1 of 2 frames selected)

2/2 Deselect all frames

Non-interactive mode

Interactive mode

Selection mode

Fit into selected frames

Normalise frames

Close selected frames
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A5	 Image menu

The Image menu displays buttons for the 
following actions

Select frame

Deselect frame

Adjust to frame

Maximise frame

Restore frame

Close frame

Several images can be opened in the working 
area.
	i Select image
	i Click on the Maximise Frame button: 
The selected image is enlarged over the entire 
working area.

	i Click on the Normalise Frame button: 
All images opened in the working area are dis-
played.

A6	 Image footer

Display of the image footer can be ad-
justed in the configuration settings (see 
„7 Configuration settings“). 

The following information is displayed:

Left side:
C.1	 Processing time of the operations
C.2	 Image load time
C.3	 Calculation time histogram

Right side:
D.1	 Mouse cursor coordinates
D.2	 Original pixel value
D.3	 Processed pixel value
D.4	 Zoom factor
D.5	 Direction of image axes

A7	 Tasks

In the Tasks dock, newly recorded images are 
displayed as a preview.
When an image is displayed in the working area, 
it is marked with a pictogram "Open in working 
area".
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Task Properties

Information on the tasks can be viewed under 
the Task Properties dock.

	i Select the task in the list.

	i Select Task Properties dock.
In the General group, changes can be made in 
the Name, Description and Manufacturer fields.

A8	 Tools

The working area contains the various tools and 
filters required for image editing (see „19.2 Tools“). 
The tools are only shown when an image is 
open in the working area.

A9	 History

All changes to the image in the working area are 
logged and saved with the image in the Opera-
tions dock.

A10	Devices

All available devices and the associated device 
information (drivers) are displayed in the Devices 
dock. 
Information on the device status is displayed on 
the right-hand side:

Temperature

Charge level

WLAN connection

LAN connection

USB device
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A11	Status bar

The following information is displayed in the sta-
tus bar at the bottom right:
	– Network connection

Clicking with the right mouse button displays 
the interface:

	– Storage utilisation (OS)

	– Memory utilisation (RAM)

	– CPU utilisation

	– GPU status

The status bar also shows running background 
processes and their progress at the bottom left 
(see „5.4 Background processes“).

5.2	 Saving concept
The "saving concept" does not require the user 
to actively save data (e.g. via a Save button). 
Other, non-image-specific changes are only 
saved when the software is closed.

5.3	 User support
For certain actions, events and warnings,  
D-Tect X generates notifications via the 
Windows Message Centre. These are divided 
into the following categories:

0 Errors / number of unread 
messages

0 Warnings / number

0 Messages / number

As soon as a notification has been generated, 
the number of notifications appears next to the 
corresponding icon.
Reading notifications:
	i Click the Notifications dock at the top of the 
working area. The list of notifications is dis-
played.

The buttons at the top left can be used to filter 
the notifications by category:

Errors

Warnings

Messages
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6	 Starting the software
There are two ways to launch the software:
	– Via the program icon on the desktop
	– Via the entry in the Windows Start menu 
Start > D-Tect X

	i Double-click the program icon on the desktop 
or

	i Select the entry in the Windows Start menu. 
D-Tect X starts.

The following configurations are required in or-
der to work with the software:
	– „14 Devices“
	– „15.1 Create task“

Notice

Risk of data loss due to incorrect 
configuration

	i Have configuration be carried out by 
DÜRR NDT or a company authorised 
to do so by DÜRR NDT.

The following buttons at the top right can be 
used to mark or delete notifications:
	– Mark as read
	– Remove all
	– Delete message

5.4	 Background processes
Running background processes are displayed 
with a progress bar in the status bar at the 
bottom left.

Detailed information can be displayed as 
follows:

	i Click the Background Processes dock.

This dock is not active by default. It 
must first be displayed via the "View" 
menu.
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Configuration

7	 Configuration settings
The configuration includes the following main sections:
	– „8 Application“
	– „9 Working area“
	– „10 Histogram“
	– „11 Tools“
	– „12 Experimental features“

Heed the warning notice!
Activating experimental features is done at your own risk and may lead to malfunction or 
crashing of the software as well as loss of data. For this reason, experimental features should 
not be activated in a productive system. 

8	 Application

8.1	 Workstation

Language The display language can be selected via the selection list. 
The software needs to be restarted after the change has 
been made.

Workstation name Display only, cannot be changed in the configuration.
File with the settings The location of the settings file. The settings file should not be 

edited manually!

8.2	 Software updates

Automatic check The automatic check can be activated/deactivated.
Update Channel Select "Stable" to receive only bug fixes and stable feature 

updates or "Daily" to always receive the latest software as 
soon as it is available.

8.3	 Output

GPU acceleration GPU acceleration can significantly improve calculation speed.
CPU threads Specifies the maximum number of CPU threads that can be 

used by the application.
OpenMP threads Specifies the maximum number of OpenMP threads that can 

be used by the application. These threads are normally used 
during image processing.
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8.4	 DRIVE NDT

Drive-NDT Enables DRIVE NDT integration. When DRIVE NDT integra-
tion is enabled, users must log in before they can use the 
software. Requires an active Internet connection.

URL URL of the DRIVE NDT server. This setting is required to ena-
ble the integration of DRIVE NDT.

9	 Working area

9.1	 Interactive mode

Mode The default mode for initial interaction:
	– Interactive
	– Non-interactive mode
	– Selection

9.2	 Image

Photometric 
interpretation reversal

If activated, the images in the working area are displayed with 
lower values as whiter pixels and higher values as black 
pixels.

Pixel smoothing If activated, the images are smoothed when zooming in (indi-
vidual pixels are less highlighted).

9.3	 Image footer

Display mode Allows switching between a permanent image footer (shows 
more extensive information, but requires more space) and an 
overlay (shows less information, but requires less space).
	– Overlay
	– Permanent
	– Never

Processing time of the operation If activated, the processing time of the operation is displayed 
in the footer of the image (not available in overlay display 
mode).

Image load time If activated, the image load time is displayed in the footer of 
the image (not available in overlay display mode).

Calculation time histogram If activated, the calculation time histogram is displayed in the 
footer of the image (not available in overlay display mode).

Mouse cursor coordinates If activated, the mouse cursor coordinates are displayed in 
the footer of the image.

Original pixel value If activated, the original pixel value is displayed in the footer of 
the image.

Processed pixel values If activated, the processed pixel value is displayed in the 
footer of the image.

Zoom factor If activated, the zoom factor is displayed in the footer of the 
image (not available in overlay display mode).

Axes If activated, the image axes are displayed in the footer of the 
image.
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9.4	 Device footer

Display mode Allows switching between a permanent image footer (shows 
more extensive information, but requires more space) and an 
overlay (shows less information, but requires less space).
	– Overlay
	– Permanent
	– Never

Mouse cursor coordinates If activated, the mouse cursor coordinates are displayed in 
the footer of the image.

Original pixel value If activated, the original pixel value is displayed in the footer of 
the image.

Processed pixel values If activated, the processed pixel value is displayed in the 
footer of the image.

Zoom factor If activated, the zoom factor is displayed in the footer of the 
image (not available in overlay display mode).

9.5	 Zoom mode

When loading image Sets the initial zoom of the element when loading.
	– Never
	– Adjusted
	– 100%

Maximise image Sets the initial zoom of the element when a picture frame is 
maximised.
	– Never
	– Adjusted
	– 100%

Normalize image Sets the initial zoom of the element when a picture frame is 
normalised.
	– Never
	– Adjusted
	– 100%

Processed pixel values If activated, the processed pixel value is displayed in the 
footer of the image.

Zoom factor If activated, the zoom factor is displayed in the footer of the 
image (not available in overlay display mode).

9.6	 Property designations

Font size Sets the default size for annotation text.
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10	 Histogram

10.1	Sketch

Type Sets the type of histogram display.
Normal
	– Logarithmic

Remove outliers If activated, new values are assigned to the histogram outliers 
based on the interquartile range.

11	 Tools

11.1	SNR

Type Sets the default SNR character type.
	– ISO 16371-1 (20x55)
	– Freehand rectangle

12	 Experimental features

Warning
Activating experimental features is done at your own risk and may lead to malfunction or 
crashing of the software as well as loss of data. 
	i For this reason, experimental features should not be activated in a productive system.
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13	 Arrange docs
The software interface of D-Tect X can be 
adapted to different needs. The different docks 
can be reordered for this purpose (e.g. move 
tasks from the left to the bottom).
Click and hold the header of the dock to be 
moved.
As soon as the dock is moved, usable areas 
within a dock are highlighted in blue and target 
markers are displayed.

E.1	 Target marker on screen
E.2	 Target marker on dock

	i Move dock to one of the target markers on 
the screen: 
The dock is placed at the top, bottom, left or 
right edge of the screen, depending on the 
selection.

	i Move dock to one of the target markers on 
the dock: 
The dock is placed above, below, to the left or 
to the right of the dock marked in blue, de-
pending on the selection.

The Layout > Reset to Default menu 
can be used to reset the layout of the 
docks to the factory settings.

14	 Devices
All devices that are available for the software are 
displayed in the list of devices.
The following conditions must be fulfilled in or-
der to display the devices in the list of devices:

	9Devices are connected to the network/work-
station.
	9Devices are switched on.
	9Device drivers are loaded.

14.1	Connecting devices
All available devices appear automatically in the 
list of devices. 
(see „14.2 Add device“).

The exact process for installation and 
configuration of a device is described 
in the assembly instructions and the 
instructions for use/installation of the 
device.

14.2	Add device

	i Select the option Available.

	i Click the symbol . 
The data for all available devices is down
loaded.

	i Click Find Devices. 
All available devices are displayed in the list.

14.3	Driver

	i Select the option Drivers: 
Information on the drivers of the available de-
vices is displayed.
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Handling

15	 Managing tasks
Every image that is managed in the software is 
assigned to a task.
Task data can be maintained directly in the soft-
ware.

15.1	Create task
A new task can be created by one of the follow-
ing actions:

F.1	 Create New Task icon

	i Click the Create New Task icon.
or

	i In the File menu, click Create New Task.
or

	i Click  in the Tasks dock.

The Create New Job pop-up appears.

	i Fill in all fields, at least the mandatory field.

It is recommended that you fill in all 
fields to enable an effective search func-
tion (see „15.2 Find task“).

	i Clicking Add Task adds the new task to the 
list under Tasks.

15.2	Find task

	i Enter information about the task (e.g. name, 
manufacturer or location) in the search field. 
The search results will be displayed in the list 
below the search field.
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15.3	Delete task
When a task is deleted, its images are deleted 
with it.

	i Select a task.
	i Select Task > Delete from the context menu.

	i Confirm the popup question on deleting the 
task. 
The task and all images associated with the 
task are deleted.

No physical deletion process takes 
place. The selected task is marked as 
deleted and removed from the task list.

16	 Record an image

16.1	Acquisition with a panel
Requirements:

	9Task is created and selected.
	9Select the device to connect to the device.
	i A new dock with the device name and view 
window appears in the working area.

	i Select the option Properties.
	i Enter the required parameters.
	i Click Livestream Start to start the livestream.

G.1	 Livestream Start/Stop
G.2	 Preview image
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H.1	 Frames
H.2	 Beam time of the last frame
H.3	 Temperature (device-dependent)
H.4	 Charge level (device-dependent)
H.5	 Device connection
H.6	 Save image
H.7	 Discard image

	i Enter the number of frames.

Application-dependent. Images are 
averaged; the more images, the better 
the quality.

	i Start acquisition by clicking . 
Acquisition stops when the number of speci-
fied frames is reached.

Acquisition can be stopped before 
the maximum number is reached by 

clicking  .

	i Save the image acquired by clicking . 
The image is added to the image list of the 
task.

	i If the result is not OK, discard the image ac-

quired by clicking  and repeat acquisition.
	i Import further images if required.
	i Click Livestream Stop to stop the livestream.

After the last image has been acquired, close 

the device view dock by clicking  at the right 
in the dock to end the connection to the device.

16.2	Acquisition with a CR scanner
Requirements:

	9Task is created and selected.
	9Select the device to connect to the device.
	i A new dock with the device name and view 
window appears in the working area.

	i Select the scanning mode from the "Scanning 
Modes" selection list.

Illustration with example, the selection depends 
on the device.
	i Select the option "Properties".

I.1	 Input fields for parameters
I.2	 Scan Start
I.3	 Scan Stop

Values for the following parameters can be en-
tered:
	– Image refresh rate (ms)
	– Recall image line step
	– Start scan delay (ms)
	i Click Start to start the scanning process.

The scanning process can be stopped 
by clicking Stop.

	i Save the image acquired by clicking . 
The image is added to the image list of the 
task.

	i If the result is not OK, discard the image ac-

quired by clicking  and repeat scan.
	i Import further images if required.
	i After the last image has been acquired, close 

the device view dock by clicking  at the 
right in the dock to end the connection to the 
device.
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17	 Importing images
The following file formats can be imported:
	– BMP (*.bmp)
	– DICOM/DICONDE (*.dcm)
	– JPEG 2000 (*.jp2)
	– JPEG (*.jpg, *.jpeg, *.jpe)
	– PNG (*.png)
	– TIFF (*.tiff, *.tif)
	– D-Tect Legacy (*.xtf)

17.1	Importing image files
Requirements:

	9Task is created
	9No other image acquisition is in progress

J.1	 Import Images icon

	i Click the Import Images icon. Select the de-
sired preset in the context menu.

or

	i Or select the context menu File > Import 
Images.

	i Select one or more image files.
	i Click Open. The images are added to the se-
lected task.

18	 Managing images
Previews of all task images are displayed in the 
image list. The images are sorted according to 
the date on which they were recorded.
	– To view or edit the images, the images are 
opened in the working area  
(see „19.1 Working area“).

18.1	Image list
The image list consists of the image archive with 
all images associated with the task.
The images in the image archive are sorted 
according to the date on which they were 
recorded.
When new images are recorded or imported, 
they are automatically added to the image list.
The following actions can be performed with 
one or more images in the image list:
	– Add to the working area
	– Export
	– Cut out (detail)
	– Copy
	– Rename
	– Delete
	– Display in Explorer
	– Divide

18.2	Load images into the working 
area

Load images into the working area in succes-
sion:
	i Double-click the image in the image list to 
load the image into the working area.

or

	i Load the image into the working area via the 
context menu Image > Add to Working Area.
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Load several images into the working area si-
multaneously:

	i Select images in the task list while pressing 
the Control key.

	i Load the images into the working area via the 
context menu Images (X) > Add to Working 
Area.

18.3	Displaying and editing image 
information

Displaying and editing image information

Settings in the image information can be 
changed, depending on the recording device.

	i Select the image in the image list.
	i Select Task Properties dock.
	i Enter and/or change the desired parameters. 
The data that has been entered or changed 
will automatically be saved.

19	 Editing images
The following navigation aids can generally be 
used:
	– Mouse wheel: zoom in/zoom out image 
section

	– Right mouse button: move image section
Reset zoom in/zoom out and move:
	– Double-click with the right mouse button

	– Click  in the "Image" menu.
The images can be edited using the tools from 
the toolbox in order to make details easier to 
recognise and assist evaluation.
The following types of image editing are possi-
ble on an X-ray image:
	– Filters
	– Transformed
	– BCG (brightness/contrast, gamma)
	– Annotations
	– Statistics
	– Analysis
	– Calibration
	i Select the image in the working area.
	i Edit the image as required using the tools. 
The editing of the image is saved.

19.1	Working area
All images selected in the image list are 
displayed in the working area. The following 
actions can be performed with the images in the 
working area:
	– „Display Images“
	– „Maximise images“
	– „Enlarging and moving image details“
	– „Close image“
	– „Clearing the working area“
	– „Displaying and managing the image status“
	– „Display/hide annotations and measurements“

Display Images

If several images are open in the working area, 
they will be displayed next to and above and 
below one another. Each of these images can 
be maximised for a detailed view.

Maximise images

If several images have been loaded into the 
working area, one image can be maximised.

	i In the Image menu, click . 
The image is maximised over the other images 
in the working area.
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	i In the menu of the maximised image, click . 
The image is normalised and all loaded 
images are displayed in the working area.

Enlarging and moving image details

When opened in the working area, the entire 
image is displayed. The image can be zoomed 
for a detailed view. The image detail displayed 
can be moved around within the frame. 
	i Click the desired image in the working area to 
select it.

	i Use the Zoom tool in the Tools dock or turn 
the mouse wheel to change the image detail.

	i To move the image detail displayed, click and 
hold the image with the right-hand mouse 
button and drag it within the frame

Close image

	i In the Image menu, click .

Result:
The image is removed from the working area.

Clearing the working area

If too many images are open in the working area 
or if the working area needs to be cleared for 
new images, all images can be removed from 
the working area.
	i Select all images in the working area.

	i In the working area menu, click . All images 
are removed from the working area.

Displaying and managing the image status

Depending on the image processing, certain 
image statuses are saved for every image. 
These can be displayed for each image. (see 
„22 History“).

Display/hide annotations and measurements

Depending on whether annotations or 
messages were added to an image, they can 
be displayed/hidden (see „22 History“).

19.2	Tools
The tools are divided into the following groups 
and can be expanded or collapsed by clicking 
► or ▼:
on an X-ray image:
	– Filters
	– Zoom
	– Transformed
	– BCG (brightness/contrast, gamma)
	– Annotations
	– Analysis
	– Calibration
	i Select the image in the working area.
	i Edit the image as required using the tools. 
The editing of the image is saved.
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Filters

Filters facilitate evaluation of X-ray images by highlighting interesting structures so that they can be 
more easily identified.

X-ray

Castings This increases the contrast for fine structures

Details 1 Medium-sized structures are enhanced while contrast is  
reduced

Details 2 Medium-sized structures are enhanced while contrast is 
balanced

Fine structures Contrast of fine structures is increased greatly

High details Contrast of smaller and medium-sized structures is increased 
greatly

Compensating filter: 
small cell / high 
compensation

Compensating filter over small cell / high compensation

Compensating filter: 
large cell / low 
compensation

Compensating filter over large cell / low compensation

Compensating filter: 
large cell / high 
compensation

Compensating filter over large cell / high compensation

High contrast Contrast of medium-sized structures is greatly increased

Blurred masking Fine structures (<2 mm) are enhanced

Regular structures Contrast of medium-sized structures is increased
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Zoom
The current zoom factor is displayed. A defined zoom factor can be 
selected.

The zoom can be adjusted to any required setting via the slider. You 
can also use the mouse wheel to adjust the zoom.

Transformations

Invert.

Reflect: X-direction

Reflect: Y-direction

Rotate 90° Clockwise

Rotate 90° Counterclockwise

ROI windowing

Trimming

BCG

Adjust the image brightness.

Adjust the image contrast.

Adjust the image gamma value
< 1: Bright areas become darker
> 1: Dark areas become brighter

Annotations

Draw a rectangle.

Draw a line.

Draw a polyline

Draw an ellipse.

Draw a spline.

Add text.

Add ruler
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Analysis

Line profile

Basic spatial resolution

Wall thickness

Signal noise ratio

ROI statistics

Contrast-to-Noise Ratio

Calibration

Calibration line

Tube calibration

Create line profile (LP)

The selected line visualises the grey scale profile 
along a drawn line.
Create line profile:

	i Click on .
	i In the image, click and hold on the start point 
with the left mouse button.

	i Draw a line and release the mouse button at 
the end point.

The greyscale profile along the drawn line is dis-
played in the LP dock.

Edit line profile

	i Click on a line in the image.
	i Change the width with the counter. 
The set value specifies the width of the  
calculation profile.

Edit line length or direction

	i Click on a line in the image. 
The anchor points of the lines are visible.

	i Move the mouse cursor onto one of the an-
chor points.

	i Press and hold the left mouse button and 
drag the anchor point to the required position.

	i Release the mouse button.

Move line

	i Click on a line in the image and move it while 
holding down the left mouse button.

	i Release the mouse button.

Determine SRb

	i Click on .
	i In the image, click and hold on the start point 
with the left mouse button.

	i With the mouse button pressed, draw a line to 
the end point.

	i Release the mouse button.
The profile of the basic spatial resolutions along 
the drawn line is displayed in the SRb dock.

Calculating the SNR

In order to calculate the signal-to-noise 
ratio, the basic spatial resolution (SRb) 
must have been set beforehand.

Statistical values on an ROI are visualised with 
this tool. The statistical values and the norma
lized SNR value are recalculated during plotting 
of an ROI when the position or size of an ROI is 
changed.
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	i Click on .
	i In the image, click and hold on the start point 
with the left mouse button.

	i With the mouse button pressed, drag a rec-
tangle to the end point and release the mouse 
button. The ROI is displayed in the image with 
the determined SNR value. Several ROIs can 
be present.

Edit size or/and location of the ROI in the 
image

	i Click on an ROI in the image. 
The anchor points of the ROI are visible.

	i Move the mouse cursor onto one of the an-
chor points.

	i Press and hold the left mouse button and 
drag the anchor point to the required position.

	i Release the mouse button.

Delete ROI

	i Activate the ROI to be deleted.
	i Delete by pressing the Delete key.

Histogram

The histogram shows the brightness distribution 
of the image.
Histogram docking allows you to alter the ima
ge's grey scale values. The black limit shows 
the percentage of grey scale values changing to 
black, and the white limit shows the percentage 
of grey scale values changing to white. If a filter 
is used then the histogram is automatically re-
calculated.
The type of histogram display and the option 
"Remove outliers" can be set in the configura-
tion. (see „7 Configuration settings“)

Measurements

In order to estimate lengths and angles 
in X-ray images, the image must be cali-
brated with the aid of a reference image 
object.
Despite calibration, this estimation is not 
as accurate as a measurement and 
must not be used as a measured result. 
The accuracy depends greatly on the 
projection distortion of the object on the 
image detector area.

Line measurement (start and end 
point, angle measurement)

Ruler (start and end point with scale 
divisions, angle measurement)

Simple line measurement

	i Click on .
	i In the image, click and hold on the start point 
with the left mouse button.

	i With the mouse button pressed, draw a line to 
the end point.

	i Release the mouse button.

Changing the display of the line

	i Double-click the line. 
The Properties: Working area dock is dis-
played.

The following settings can be displayed and 
changed:
General
	– Name
	– Remarks
	– Scalable element
	– Movable element
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Geometry
	– Length
	– X-distance
	– Y-distance
	– Angle

Position
	– Point 1 (start point)
	– Point 2 (end point)
	– Mid-point

Measure with ruler

	i Click on .
	i In the image, click and hold on the start point 
with the left mouse button.

	i With the mouse button pressed, draw a line to 
the end point.

	i Release the mouse button.

Changing the display of the line

	i Double-click the line. 
The Properties: Working area dock is dis-
played.

The following settings can be displayed and 
changed:
General
	– Name
	– Remarks
	– Scalable element
	– Movable element

Geometry
	– Length
	– X-distance
	– Y-distance
	– Angle

Position
	– Point 1 (start point)
	– Point 2 (end point)
	– Mid-point

Display
	– Marking length
	– Division spacing

Drawings

Drawings can be inserted into the image.
All drawings are saved as operations.
The following drawing tools are available:

Rectangle

Line

Polyline

Spline

Ellipse
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Create a rectangle

	i Click on .
	i In the image, click and hold on the start point 
of the rectangle with the left mouse button.

	i With the mouse button pressed, draw a rec-
tangle to the end point.

	i Release the mouse button.

Create a line

	i Click on .
	i In the image, click and hold on the start point 
of the line with the left mouse button.

	i With the mouse button pressed, draw to the 
end point.

	i Release the mouse button.

Creating a polyline of spline

	i Click  or .
	i In the image, click and hold on the start point 
of the line with the left mouse button.

	i With the mouse button pressed, draw the line 
to the first mid-point and click.

	i With the mouse button released, draw the line 
to the second mid-point and click.

	i Repeat the process for all additional points.
	i Set the end point by double-clicking with the 
right mouse button.

	i Release the mouse button.

Changing the display of the line

	i Double-click the line. 
The Properties: Working area dock is dis-
played.

The following settings can be displayed and 
changed:

General

	– Name
	– Remarks
	– Scalable element
	– Movable element

Geometry

	– Length
	– X-distance
	– Y-distance
	– Angle

Position

	– Point 1 (start point)
	– Point 2 (end point)
	– Mid-point

Create an ellipse

	i Click on .
	i In the image, click and hold on the start point 
of the ellipse with the left mouse button.

	i With the mouse button pressed, draw an 
ellipse to the end point.

	i Release the mouse button.

Changing the rectangle/ellipse display

	i Double-click the object drawn. 
The Properties: Working area dock is dis-
played.
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The following settings can be displayed and 
changed:
General
	– Name
	– Remarks
	– Scalable element
	– Movable element

Geometry
	– Dimension
	– Area

Position
	– Point 1 (start point)
	– Point 2
	– Point 3
	– Point 4
	– Point 4
	– Mid-point
	– Position

Changing text properties

Also see Presetting the font size:
	– „9.6 Property designations“

The text size, text colour and text background 
can be adjusted for all tools in the Annotations 
group.
Requirements:
	– In the Properties: Working area dock, the 
option "Display property in the working area" 
is enabled for at least one parameter.

	i Double-click the text field. 
The Properties: Working area dock is dis-
played.

The following settings can be changed:
Font
	– Colour
	– Filling
	– Size

Background
	– Colour
	– Position

Moving the text field

	i Click on the text field with the left mouse but-
ton and move it to the desired position while 
keeping the mouse button pressed.

	i Release the mouse button.

Calibration

Calibration line

	i Click on .
	i In the image, click and hold on the start point 
with the left mouse button.

	i With the mouse button pressed, draw a line to 
the end point.

	i Release the mouse button.

Tube calibration

	i Click on .
	i In the image, click and hold on the start point 
with the left mouse button.

	i With the mouse button pressed, draw a line to 
the end point.

	i Release the mouse button.
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20	 Export image

20.1	Default
Various defaults can be defined and saved for 
image export.

K.1	 Export Images icon

	i Click the Export Images icon.
	i Select Create New Defaults in the context 
menu.

The following settings can be selected during 
the user-defined export
	– Format
	– Image options
	– Objective
	– Export option
	–  Summary

Format

The following image formats are available:
	– JPEG
	– PNG
	– TIFF
	– BMP
	– DICONDE

Image options

The selection of image options depends on the 
image format:
	– JPEG/PNG/TIFF/BMP

	– Displaying annotations on the image
	– Export image metadata JSON file

	– DICONDE
	– Export image metadata JSON file

Objective

	– Select the image export directory

Export options

	– Open folder after export
	– Create a subfolder for each task

 Summary

All selected options are listed.
	i Enter a name for the new defaults in the 
"Name" input field.

	i In the Summary dock, click Create Default.
The selected settings for the user-defined export 
are saved locally and can be reused during the 
next export.
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20.2	Exporting images
	i Select an image or several images in the 
Tasks list.

K.1	 Export Images icon

	i Click the Export Images icon.  
Select the desired default in the context 
menu.

or

	i Select the image via the context menu File > 
Export Images.

	i In the Summary dock, click Export.

21	 Deleting images
If images are no longer required, they can be 
deleted.

	i Select the image in the image list.
	i Select Image > Delete from the context 
menu.

	i Confirm the question on deleting the image. 
The image is deleted.
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22	 History
All work steps on the image in the workspace 
are logged and permanently saved with the im-
age in the History dock.

The following data is saved chronologically:
	– Tool used
	– Date and time
	– Editing time
	– Current status

Activating/deactivating the status

To the left of the tool icon there is an icon for the 
current status of a work step.

L.1	 Work step enabled
L.2	 Work step disabled

An executed work step cannot be undone. It 
can be disabled via the status. It remains stored 
and can be re-enabled if necessary.

Enabling a work step

	i Click on .
All operations performed in the work step are 
applied to the image.

Disabling a work step

	i Click on .
All operations performed in the work step are 
removed from the image.

23	 Licensing

23.1	Activating a licence online

An active internet connection is required 
to activate the licence.

	i Open the Software Licence dock via the 
Help > Licence menu.

	i Enter a valid licence key.
	i Click Activate.

23.2	Activating a licence offline
For PCs that are not connected to the Internet, 
there is a special offline activation procedure.
You can find more information at: 
https://dtectx.com/activation
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23.3	Deactivating a licence online

An active internet connection is required 
to deactivate the licence.

	i Open the Software Licence dock via the 
Help > Licence menu.

	i Click the Deactivate button.

	i Answer the query:
No 	 Licence is deactivated
Yes	 Licence is deleted from the computer

23.4	Deactivating a licence offline
For PCs that are not connected to the Internet, 
there is a special offline deactivation procedure.
You can find more information at: 
https://dtectx.com/activation

23.5	Updating a licence

An active internet connection is required 
to update the licence.

	i Open the Software Licence dock via the 
Help > Licence menu.

	i Enter the licence key.
	i Click the Update button.
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Notes
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